Router dinamik yapılandırma – Rip V2-

rip v2

rip v2

Mantıksal topoloji;

Router Ip Adres Arayüz DTE/DCE
Router0 10.0.0.6/30 s 0/0 DTE
Router0 10.0.0.9/30 s 0/1 DTE
Router0 fa 0/0
Router0 172.16.10.1/24 fa 0/0.10
Router0 172.16.20.1/24 fa 0/0.20
Router1 10.0.0.5/24 s 0/0 DCE (clock rate…56000)
Router1 10.0.0.1/24 s 0/1 DTE
Router1 172.16.30.1/24 fa 0/0
Router2 10.0.0.10/24 s 0/0 DCE (clock rate…56000)
Router2 10.0.0.2/24 s 0/1 DCE (clock rate…56000)
Router2 172.16.40.1/24 fa 0/0
PC
PC0 172.16.10.2/24 fa 0/1
PC1 172.16.10.3/24 fa 0/2
PC2 172.16.20.2/24 fa 0/1
PC3 172.16.20.3/24 fa 0/2
PC4 172.16.30.2/24 fa 0/1
PC5 172.16.30.3/24 fa 0/2
PC6 172.16.40.2/24 fa 0/1
Sunucu0 172.16.40.3/26 fa 0/2

******************************************************

Hedefler

  • Cisco Router 2621XM aygıtının, dinamik yönlendirme yapılandırmasını gerçekleştireceğiz. Yönlendirme protokolü olarak RIPV2 kullanacağız.

Kaynak

  • Router yönlendirme bilgisi yönetici tarafından statik bir şekilde yapılandırılabildiği gibi dinamik olarak yönlendirme protokolleri ile de gerçekleştirilebilir. RIP, IGRP, OSPF, EIGRP gibi çeşitli dinamik yönlendirme protokolleri vardır. Her protokolün kendine ait özellikleri vardır. Bu modülümüzde dinamik yönlendirme protokollerinden RIPV2 protokolünü öğreneceğiz.
  • RipV2 hem classless hem de classfull olarak çalışabilen bir protokoldür. Varsayılan olarak yapılandırıldığında classfull olarak çalışır. Classless olarak yapılandırmak için, yönlendirme yaparken “no auto summary” özelliği aktif edilmelidir.

Adım 1. Senaryodaki router aygıtlarını prototip programınızda kullanın.

Adım 2. CLI arayüzüne girerek Switch0 aygıtında vlan bilgileri ekleyip, arayüzlere atayın.

…: Switch0’a vlan bilgilerini ve atama bilgilerini girin

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#vlan 10

Switch(config-vlan)#name vlan10

Switch(config-vlan)#exit

Switch(config)#vlan 20

Switch(config-vlan)#name vlan20

Switch(config-vlan)#exit

Switch(config)#vlan 30

Switch(config-vlan)#name vlan30

Switch(config-vlan)#exit

Switch(config)#interface FastEthernet0/1

Switch(config-if)#switchport access vlan 10

Switch(config-if)#exit

Switch(config)#interface FastEthernet0/2

Switch(config-if)#switchport access vlan 20

Switch(config-if)#exit

Switch(config)#interface FastEthernet0/24

Switch(config-if)#switchport mode trunk

Adım 3. CLI arayüzüne girerek sırasıyla router aygıtlarının arayüzlerine ip bilgilerini atamak için aşağıdaki kodları uygulayın.

…: Router0’a ip bilgilerini girin

Router(config)#int s 0/0

Router(config-if)#ip address 10.0.0.6 255.255.255.252

Router(config-if)#no sh

Router(config-if)#int s 0/1

Router(config-if)#ip address 10.0.0.9 255.255.255.252

Router(config-if)#no sh

Router(config-subif)#int fa 0/0.10

Router(config-subif)#encapsulation dot1Q 10

Router(config-subif)#ip address 172.16.10.1 255.255.255.0

Router(config-subif)#no sh

Router(config-subif)#int fa 0/0.20

Router(config-subif)#encapsulation dot1Q 20

Router(config-subif)#ip address 172.16.20.1 255.255.255.0

Router(config-subif)#no sh

Router(config)#interface fa 0/0

Router(config-if)#no sh

…: Router1’a ip bilgilerini girin

Router(config)#int s 0/0

Router(config-if)#ip address 10.0.0.5 255.255.255.252

Router(config-if)#no sh

Router(config-if)#cl r 56000

Router(config-if)#int s 0/1

Router(config-if)#ip address 10.0.0.1 255.255.255.252

Router(config-if)#no sh

Router(config-if)#int fa 0/0

Router(config-if)#ip address 172.16.30.1 255.255.255.0

Router(config-if)#no sh

…: Router2’a ip bilgilerini girin

Router(config)#int s 0/0

Router(config-if)#ip address 10.0.0.10 255.255.255.252

Router(config-if)#no sh

Router(config-if)#cl r 56000

Router(config-if)#int s 0/1

Router(config-if)#ip address 10.0.0.2 255.255.255.252

Router(config-if)#no sh

Router(config-if)#cl r 56000

Router(config-if)#int fa 0/0

Router(config-if)#ip address 172.16.40.1 255.255.255.252

Router(config-if)#no sh

Bu ana kadar olan yapılandırma bilgilerini doğrulamak için bilgisayarların kendi ağ geçidi ile haberleşebileceğini görün.

Adım 3. Router aygıtlarına ripV2 yönlendirme bilgilerini girin.

…: Router0 ripV2 yapılandırmasını girin

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 10.0.0.4

Router(config-router)#network 10.0.0.8

Router(config-router)#network 172.16.10.0

Router(config-router)#network 172.16.20.0

Router(config-router)#no auto-summary

…: Router1 ripV2 yapılandırmasını girin

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 10.0.0.4

Router(config-router)#network 10.0.0.0

Router(config-router)#network 172.16.30.0

Router(config-router)#no auto-summary

…: Router2 ripV2 yapılandırmasını girin

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 10.0.0.0

Router(config-router)#network 10.0.0.8

Router(config-router)#network 172.16.40.0

Router(config-router)#no au

Router(config-router)#no auto-summary

Adım 4. Router0 yapılandırma bilgisini sunucuya kaydedin.

Router#ping 172.16.40.3

Sending 5, 100-byte ICMP Echos to 172.16.40.3, timeout is 2 seconds:

!!!!!

Router#copy run tftp

Address or name of remote host []? 172.16.40.3

Destination filename [Router-confg]? R0conf

!!

[OK – 860 bytes]

Sunucuya yapılandırmaları kaydetme işlemini diğer router aygıtları içinde kullanın.

Adım 5. Telnet bağlantısı için router0 telnet ve enable şifreleri girin.

Router(config)#enable secret ena123

Router(config)#line vty 0 4

Router(config-line)#password vty123

Router(config-line)#login

Telnet yapılandırmaları işlemini diğer router aygıtları içinde kullanın.

Yukarıdaki yapılandırmaların tamamı gerçekleştiğinde, bütün bilgisayarların birbiri ile haberleşiyor olması, sunucuya yapılandırmaların yedeklenmiş olması ve router aygıtlarına uzaktan telnet ile erişim yapılıyor olması gerekir.

Paket Tracer Uygulamasını indirebilirsiniz

Aziz BEKTAŞ

Tuzla Teknik Lisesi

Bir Yanıt

  1. […] Router dinamik yapılandırma – Rip V2- […]

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Connecting to %s