Cisco 877 ADSL yapılandırması

Bu sefer bir 877 üzerinde ADSL yapılandırması gerçekleştirip iç taraftaki ağı Internet’e çıkaracağız.

İlk önce ATM0 interface’ini yapılandıralım.

router>enable
router#conf t

router(config)#int atm 0
router(config-if)#no ip address
router(config-if)#dsl operating-mode auto
router(config-if)#pvc 8/35
router(config-if-atm-vc)#pppoe-client dial-pool-number 1
router(config-if-atm-vc)#exit-vc
router(config-if)#no shutdown

Buradaki “dsl operation-mode auto” komutu aslında default.  Girmeseniz de olur. “pppoe-client dial-pool-number 1″ komut ile de kullanacağımız dialer interface’i tanımlamış oluyoruz.

Şimdi Dialer0 interface’ini yapılandıralım

router(config)#int dialer 0
router(config-if)#ip address negotiated
router(config-if)#encapsulation ppp
router(config-if)#dialer pool 1
router(config-if)#pap authentication pap callin
router(config-if)#ppp pap sent-username kullaniciadi@ttnet password sifreniz
router(config-if)#ppp ipcp dns request
router(config-if)#ip nat outside
router(config-if)#mtu 1492

“ip address negotiated” diyerek IP adresini PPP ile alacağımızı söylüyoruz. “dialer pool 1″ diyerek bu interface’in pool adresini 1 olarak belirliyoruz. Biraz önce ATM interface’inde bu değeri kullanmıştık. Şu komuta dikkat “pap authentication pap callin” bu komuttaki callin parametresini girmezseniz çalışmıyor. Saatlerce debelendim. Sağolsun Umut’un conf’undan gördüm. Sadece gelen isteklerde authentication gerçekleştir gibi bir parametre:)

Şimdi iç ağın çıkacağı IP‘yi belirleyelim.

router(config)#interface vlan1
router(config-if)#ip address 10.0.0.2 255.255.255.0
router(config-if)#ip nat inside

NAT yapalım

access-list 101 permit ip 10.0.0.0 0.0.0.255 any
ip nat inside source list 101 interface dialer0 overload

DHCP’yi ayarlayalım

router(config)#ip dns server
router(config)#ip dhcp pool clients
router(dhcp-config)#import all
router(dhcp-config)#network 10.0.0.0 255.255.255.0
router(dhcp-config)#default router 10.0.0.2
router(dhcp-config)#dns-server 10.0.0.2

Bu ayarlardan sonra kullanıcılar Internet’e çıkabilmeli.

Esen kalın.

alıntı

2 Yanıt

  1. elinize sağlık.çok iyi oldu çokda güzel i

  2. […] Cisco 877 ADSL yapılandırması […]

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Connecting to %s